Marsa33 power issue

Discussion in 'Rocketry Electronics and Software' started by Cameron Anderson, Aug 11, 2019.

Help Support The Rocketry Forum by donating:

  1. Aug 11, 2019 #1

    Cameron Anderson

    Cameron Anderson

    Cameron Anderson

    Well-Known Member

    Joined:
    Sep 14, 2018
    Messages:
    342
    Likes Received:
    93
    Gender:
    Male
    Location:
    Reno, NV
    I have a new Marsa33 and the only way I can get it to power up is by wiggling the battery wires once they're connected. I'm using tested 9v batteries and different 9v connectors with different types of wires and the problem persists.

    Any ideas?
     
  2. Aug 11, 2019 #2

    mikec

    mikec

    mikec

    Well-Known Member

    Joined:
    May 9, 2009
    Messages:
    2,007
    Likes Received:
    85
  3. Aug 11, 2019 #3

    Cameron Anderson

    Cameron Anderson

    Cameron Anderson

    Well-Known Member

    Joined:
    Sep 14, 2018
    Messages:
    342
    Likes Received:
    93
    Gender:
    Male
    Location:
    Reno, NV
    I think it's a bad joint - I switched the suspect Marsa for my second one (using the existing power connection and switch on my sled) and it works fine.
     
  4. Aug 11, 2019 #4

    Cameron Anderson

    Cameron Anderson

    Cameron Anderson

    Well-Known Member

    Joined:
    Sep 14, 2018
    Messages:
    342
    Likes Received:
    93
    Gender:
    Male
    Location:
    Reno, NV
    Typical great Marsa service - John is replacing my 33. I emailed asking for troubleshooting assistsnce and he replied in two hours.
     

Share This Page