Quantcast

Windows x64 compatibility with PerfectFlite, BeeLine, and PICO

The Rocketry Forum

Help Support The Rocketry Forum:

jcsalem

Well-Known Member
Joined
Feb 26, 2009
Messages
451
Reaction score
0
I'm having trouble connecting to my PerfectFlite MAWD and BeeLine TX when running from the x64 bit version of Windows 7. Windows Vista x64 should have the same issues.

Has anyone had success connecting to either of those devices from a 64-bit version of Windows? I'm going through a new RadioShack USB to serial adapter to try and connect and it shows up correctly in device manager.

I'd like to know whether others have had success connecting with Vista x64 or Win7 x64 so I can decide whether the problem is the rocketry software or the USB-to-serial adapter.

Thanks in advance!

Jim
 

n5wd

Well-Known Member
Joined
Jan 18, 2009
Messages
1,030
Reaction score
2
Has anyone had success connecting to either of those devices from a 64-bit version of Windows? I'm going through a new RadioShack USB to serial adapter to try and connect and it shows up correctly in device manager.

I'd like to know whether others have had success connecting with Vista x64 or Win7 x64 so I can decide whether the problem is the rocketry software or the USB-to-serial adapter.
I'm using Vista Home Premium with the Bee and Perfectflite Alt15K and MAWD data programs and they work fine, as long as you're running in administrator mode.
 

Rocketjunkie

Addicted to APCP
Joined
Jan 19, 2009
Messages
4,124
Reaction score
348
When I used a Radio Shack USB/serial adapter, it would come up as a different port number each time I plugged it in. I had to go into the properties and set the adapter to port 4. It now comes up as port 4 no matter which USB port I plug it into. Each time I use the Perfectflite software, I have to set it to port 4 as it defaults to port 1 and won't recognize the adapter or altimeter.
 

DavyRocket

New Member
Joined
Jul 16, 2010
Messages
3
Reaction score
0
I'm having trouble connecting to my PerfectFlite MAWD and BeeLine TX when running from the x64 bit version of Windows 7. Windows Vista x64 should have the same issues.

Has anyone had success connecting to either of those devices from a 64-bit version of Windows? I'm going through a new RadioShack USB to serial adapter to try and connect and it shows up correctly in device manager.

I'd like to know whether others have had success connecting with Vista x64 or Win7 x64 so I can decide whether the problem is the rocketry software or the USB-to-serial adapter.

Thanks in advance!

Jim
I'm having this problem right now. I have 2 Win7 x64 machines - a netbook with Win7 Home Premium and a laptop with Win7 Pro. The Perfectflite DT2U plugs&plays just fine on the laptop, but not on the netbook.

So far, I've traced the problem to a missing driver. The DT2U uses the FTDI FT232R USB UART, which has hardware ID USB\VID_0403&PID_6001&REV_0600. I found a driver install file on the FTDI website and installed it. The driver now loads and the Device Manager entry looks ok, but Alt15DataCap doesn't see any comm ports; the dialog shows four 'Not present' greyed-out buttons. Interestingly, on the laptop, it also shows four 'Not present' buttons but the first one is selectable. Running Alt15DataCap in Admin mode doesn't help.

Has anyone been down this path before?

Thanks!

Dave
 

JDcluster

Well-Known Member
Joined
Feb 23, 2009
Messages
5,319
Reaction score
83
Location
New Jersey
I haven't tried to install the program yet but it should work under XP mode virtual machine if all else fails....


JD
 

dmjung

Well-Known Member
Joined
Jun 16, 2010
Messages
61
Reaction score
0
I haven't tried to install the program yet but it should work under XP mode virtual machine if all else fails....
JD
Probably would...I ended up getting up off my lazy butt and using my XP laptop. No problems there of course.
 

jackman

Well-Known Member
Joined
Feb 12, 2009
Messages
97
Reaction score
0
Location
Monroe, Oregon
Has anyone been down this path before?
I got it to work with Windows 7. I let Windows find the latest driver after plugging the USB/serial adapter into the computer. Then I changed the serial port to COM 2 as follows:

Right click computer and select manage, expand Device Manager, and expand Ports, find the USB serial port and right click, then select "Port Settings", click "Advanced", and you can change the COM port number to an unused number 9 or less. The default is COM 3 but that was already taken on my computer so I selected COM 2 instead.

Then in the MAWD DATA capture program I selected the first instance of "Not present" and it found the MAWD just fine.

I hope that helps. BTW, the PerfectFlight folk, in an e-mail to me, stated they are working on a new version of the software.
 
Top