TeleMega not working properly

The Rocketry Forum

Help Support The Rocketry Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

irami023

New Member
Joined
Jan 29, 2023
Messages
1
Reaction score
0
Location
Usa
As part of our subscale eBay, we have a telemega that acts as a secondary flight computer.

We fully charged it a week early and it had a green light. However, the day before our launch we go to check if it is working properly and battery hasn’t drained.

The TeleMega light does not turn on at all when we go to check the battery charge. We check the cable and it works fine. We use a multimeter and the battery is 90% charged. But still no light indicator turns on.

We turn on the Telemega and it turns on and gives off a sequence of beeps but still no light.

We try plugging it into various computers and it doesn’t show up on either computer. We try connecting a teledongle and it shows up on the AltusUI but the telemega does not show up at all. We try to configure the altimeter and it says “altimeter already in use cannot configure”. It does not show up on any channels or frequencies on the AltusUI.

Can anyone help with this issue? We tried holding it horizontally and vertically, alternating having it on and off before starting up the program.
 

Latest posts

Back
Top