Quantcast

Sirius Refit USS Atlantis Build

The Rocketry Forum

Help Support The Rocketry Forum:

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Glued the motor mount tube in, but only the forward two centering rings right now, will install the two aft centering rings when I install the pylons.

In the pic, it looks like the middle ring is not even with the upper edge of the pylon slot, but it is flush.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
I also glued the antenna dish on, and now realize I should have waited until after I painted it. Now I will have to either hand paint is at the end or do some complex masking. C'est la vie.
 

Vitruvius

Well-Known Member
TRF Supporter
Joined
Nov 11, 2019
Messages
172
Reaction score
55
Man, this is one "Fascinating" Build! I look forward to seeing how You do this.
 

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Got the pylons installed. Used the Estes fin jig to keep the straight. worked out pretty well. Used yellow glue on the root edges of the pylons to glue them in, then med cure epoxy to bond them to the body tube, looks pretty clean right now.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Once the epoxy was dry, I installed the two aft centering rings.

Couple notes here really quick on the centering rings. I am using centering rings from a bag if spares I got at Sirius. They are made from thick cardboard. The interesting thing is that not a single one of them is exactly the same size. Some are loose/tight on the inner diameter and some are loose/tight on the outer diameter. So, I tried a bunch to get the fit I wanted for the two I was using. I have come to actually like the fact that these all fit differently because I encounter different situations.

In this case, I wanted the centering ring on the upper part of the pylon to be tight on both the inner and outer diameter because it was glued onto the motor mount tube first and installed with the whole assembly. It forms the upper bracket for the pylon. But the lower centering needs to pushed down a narrow gap 2.5 inches down the tube with glue in it's way, so I chose one that was pretty loose on the inner and out diameter.

The gap between the motor mount tube and the body tube is about 1/4", so I split a 3/16" dowel length wise and used one of the these thin sticks to spread some medium cure epoxy as low down the motor mount tube as i could get it. I used epoxy because I didn't want the centering ring to bind up on yellow glue.

I then used both sticks to push the centering down the motor mount tube until it butted up against the pylon. You can see in the picture the centering ring just behind the pylon in the gap between the pylon and the motor mount tube.

Finally, I installed the rear wood centering ring with yellow glue. The instructions tell you to make it flush with the end of the BT, but I am going to install the retainer threads, so I pushed the centering back about 1/8" just to give me a little room.

Once everything was dry, put some white glue fillets everywhere.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
While all that was drying, I cut out the bridge and glued it to the main deck. I left a little bit of plastic on the bridge for better adhesion. It was a bit too wide for the deck that way, but I decided to keep it and trim the bridge flush once it was glued on. Kind of like the way it turned out.

For the actual gluing, pretty simple. Traced a line around the bridge, sanded off the primer, then, using tape on one end as a hinge, lifted the bridge up, lathered some plastruct around the space I just sanded and lowered it in place. Good bond. Dries quick, so was also able to fillet the edges with some Vallejo plastic putty to smooth the transition.

While I was at it, I sealed the edges of the main deck with some finishing cure epoxy, which also helped to lock down any stray loose paper edges from the skin.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Okay, last thing for tonight - glued the threads on for the retainer. Used the E12-4 motor to keep everything perfectly centered (the estes threads are a little loose around the BT-50 tube). Tape on the motor was to keep it from sliding too far into motor mount tube while the epoxy is drying. Love JBWeld, but this stuff takes hours to set and cure, so will let this sit overnight.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Got the side decks glued on with yellow glue and held in straight and in place with rubber bands. Also glued the baffle/coupler into the lower body tube with yellow glue.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Sanded the second coat on the nose cone, nice and smooth now. Going to give it s shot of primer, then set it aside
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Back to the nacelles. Once the Tamiya putty was dry, I sanded the edges and ends smooth. Everything came out quite well, I think, but there were a number of gaps, cracks, etc. For all those, I used Vallejo plastic putty. Just apply some to the area and smooth with your finger, works well.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Once the plastic putty dried, I lightly sanded everything and the nacelles are ready to install. BY not choosing to use the styrene strips, the nacelles are more rounded than other builds. I could add the strips to add the squared off relief on the edges and sides, but I kind of like them rounded, so I plan to keep them like this. So far, using putty to fill the large and small gaps has made the nacelle work pretty easy and quick.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Once the side decks dried, I attached the kevlar shock cord to the eye screw on the baffle with a bowline and a couple half-hitches with some yellow glue rubbed in to keep the not from coming apart. Then, before gluing the upper body tube in place, I measured and marked where I wanted the upper loop on the kevlar cord so it would end up just below the lip of the upper tube when complete to prevent zippering.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
The next pieces to install are the main deck and the conduits, but they extend beyond the lower BT, so need the upper BT in place now. Glued the upper BT to the baffle/coupler with yellow glue, filled the gap with CWF and primed.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Sanded the primer away from the main deck and conduit glue points, then remarked the body lines for those pieces. Glued the conduits in place and held on with rubber bands and tape while drying.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Last pieces to add to the bottom were the launch lugs. Replaces the 3/16" lugs that came with the kit and installed 1/4' lugs using the same measurements in the instructions. Before installing the lugs, I filled the seams with CWF and gave the inside of the lugs a coat of thin CA, followed by sanding with 150 grit then 320 grit sandpaper glued to a stick. Then installed the lugs according to the instructions. Once this was complete, I gave all parts white glue fillets that needed them.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Been going at this one in binges :) took a couple days off over the weekend, then a flurry of progress. Working from home during COVID provides some good opportunity to make progress during the day. Used to be that my weekends were the time I worked on rockets, but now it is the opposite. Weird world we live in these days!
 

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Main deck is on. Clamped the belly fin in my panavise and leveled the rocket out length wise, then used a small bubble level with double sided tape to ensure the main deck was glued on level. Glued with yellow glue, clamped and taped. Will fill in all the fillets after it is dry with white glue and prob have to wait until tonight or tomorrow to let everything dry before I start messing with putting the nacelles on the pylons.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Next up, installing the nacelles. I cut the slots into the nacelles with a new blade. I cut the slots relatively narrow because I wanted a tight fit. I trimmed and sanded as necessary to get them to fit on the pylons. The tenon on the pylon is very long. The instructions do say you should sand the pylon to get the length right. I have not been able to determine if the nacelle should be flush to the end of the pylon, but, as you can see from the photo, there is a solid 1/8" gap between the pylon and the nacelle. Further, since the end of the pylon tenon is square, it wants to cant the nacelle out on an angle. It appears from the instructions, the nacelles should be vertical and square to the body.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
In the absence of further info, I decided to make the nacelles flush to the pylon. Also, I figured that sanding the tenon on an angle would help it rest more fully against the curved BT-5 tube and provide both a better internal gluing surface and help alleviate the outward canting of the nacelle when installed.

So, I got my sanding block with 80 grit, added some elbow grease, and sanded the tenons down.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
After that, the nacelles fit nicely. I decided to use yellow glue to attach them (was waffling between yellow glue and epoxy - thought the yellow glue should give a decent bond between the wood tenon and the paper BT-5). Lathered the ends of the tenons up, installed, taped square and will let dry for most of today before messing with it again.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Forcing the nacelles into the narrow slot broke open the seams on the nacelle edges nearby. One is minor, the other opened up pretty good.

Turned out to be an easy fix once I realized the small detail pieces of wood go exactly over where the broken seams are.

So I closed up the seams with thick CA and used CA accelerator to make it harden instantly. Smoothed out the seam by sanding it, then used quick cure epoxy to put the detail sticks on. Sealed the seams nicely, nice and strong now, and the detail pieces look fine.

Will let this all dry and fill any gaps with fillets.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Shot some primer at the joints and seams. Going to sand some areas, clean up the base of the nose cone and shoot a first color coat.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
I put a coat of the "Brilliant Aluminum" on. It has a metallic finish that not quite glossy, not quite matte. On the other hand, it shows each and every blemish!. Have some cleaning up to do after this coat before I decide if I want to use it for the final color coats. Paint job aside, everything looks good structurally.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
After quite a bit of detail filling and sanding, this ship is as smooth as my patience is going to allow. Stuck with the Krylon Brilliant Aluminum. Still have to tackle the four decal sheets, do the details painting and get the recovery system in place, but the main color coat is on now.
 

Attachments

neil_w

Chuffed as ninepence
TRF Supporter
Joined
Jul 14, 2015
Messages
9,541
Reaction score
2,712
Location
Northern NJ
Pretty. Look forward to seeing how that metallic finish looks with decals.
 

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
Was staring at the aluminum paint/metallic finish and all the gray and black decals and decided it was going to be too dark. At least 30% of the decals would have blended right in. That's when I took a bit of a right turn at Albuquerque and ended up at a different place altogether. Went back to my original idea of going completely off-book here and went light blue. Had a new can of Testors Light Blue Enamel sitting around and went for it. Testors little enamel cans can be finicky to work with and have a tendency to drip like crazy. I only had the one can, so knew I wasn't likely to get two full coats out of it, so was very careful on the application. Came out perfect. Testors enamel is like a shell when it dries. Hides every little blemish. Will let it off gas for a couple days, then decals.

IMG_20200816_194817.jpg
 

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
It has been a while since I posted on this build, but I didn't abandon it!

Back in August, I finished it and painted it blue as the above post shows. I got all the decals on and then pulled a bonehead rookie move - I put way too much clear coat on. Completely alligatored the finish and ruined a bunch of the decals. Sigh.

So, I put it aside and worked on other projects and periodically (and painstakingly) sanded it down to wood and cardboard. Also, I contacted David at Sirius to purchase another set of decals and he sent me another set out immediately at no charge. Amazing customer service. Suffice to say, I used to own a couple Sirius rockets. I now have all of them in my build pile.
 

Attachments

mtnmanak

Well-Known Member
TRF Supporter
Joined
May 5, 2020
Messages
107
Reaction score
69
Location
NJ & PA
I finally got the rocket repainted last weekend and finished up over the past couple days. Instead of the regular Testor's light blue, I used a can of Model Master's light blue I had hanging around. It is darker than the regular Testor's and the Model Master paint is so nice. Pour one out for Model Master...

One of the first things I noticed was that the engine retainer cap from the Estes 24mm retainer I used was going to interfere with the 1/4" launch lugs. So I made a couple adjustments. First, I filed down the cap so the launch lugs would be clear and then I installed red rail buttons on the bottom. I have move almost all my rockets to rail launch now, regardless of size, and the red ones went nice on the bottom of this rocket. Kind of looks like red lights.
 

Attachments

Top