Rocksim problem

The Rocketry Forum

Help Support The Rocketry Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Jimmy F.

Well-Known Member
Dec 11, 2011
Reaction score
So I changed OS and then reinstall Rocksim and getting this error, cant get past this
any help out there?

Tried that and nothing changes, the windows just closes and all remains the same. The manual selection, it wants to reload motor data, so chose from the list and all remains the same. And cancel... well. Tried just about everything short of re-install the software, which I think is my next step.
Thanks for the query.
Old OS = Vista
New OS = Win 7
The data files are where they are supposed to be, checked that already. I think something screwy happened with my user name in the update process. I'm thinking the software can't follow the path to the engine files because of this.
First thing I would do is to download new motor files. The reinstall may be missing some motors you updated/added. I would suggest my complete by manufacturer motor files. Download the ones you need from here (username and password are both guest):

Copy the new motor files to the directory your motor files are in.

Open Rocksim, but not a design. Click file and reload engine data. Remove all current motor files from the selected list, and add the new ones you just downloaded. Click OK. Open a rocket and see if the error reoccurs, and report back.
You say that the files are where they are supposed to be. Where did you look? According to the Rocksim FAQs, they are not in the \data directory where Rocksim is installed. Rather, they are in: