problems with Estes Electron Beamer

The Rocketry Forum

Help Support The Rocketry Forum:

rocketsonly

Well-Known Member
Joined
Apr 7, 2004
Messages
881
Reaction score
0
Is it just me, or is there a defect in the safety keys for these units? Of the 3 units that I have (2 of them were leftovers from a rocket camp at my school, the teacher also gave me some motors :D ), the safety pin is too narrow for the key slot. Meaning, the pin doesn't conduct the electricity from one side to the other. Anyone have the same problem?
 

rabidsheeep

Well-Known Member
Joined
Jan 27, 2009
Messages
1,634
Reaction score
2
are these the new ones with the rubber? are you pushing HARD all the way down?

maybe the metal peice is bent on the inside, just pop it open and check, then glue or just duct tape it back together
 

DynaSoar

Well-Known Member
Joined
Mar 15, 2004
Messages
3,022
Reaction score
0
Originally posted by rabidsheeep
are these the new ones with the rubber? are you pushing HARD all the way down?

maybe the metal peice is bent on the inside, just pop it open and check, then glue or just duct tape it back together
Like he sez.

The contacts were sprung in two I got on auction with parts loads. I opened them and bent them back (among other things).

If you do this, look over the Estes controller mods in this year's NAR member guide. Swap the lamp for a buzzer, and rig it for external (larger) battery.
 

rocketsonly

Well-Known Member
Joined
Apr 7, 2004
Messages
881
Reaction score
0
Cool, thanks for the advice. I did however replace the 'new' key with the older style key which is thicker; it worked flawlessly!
 
Top