Quantcast

PerfectFlite Alt15K/WD Data Acquisition Problem

The Rocketry Forum

Help Support The Rocketry Forum:

GregGleason

Well-Known Member
Joined
Nov 13, 2009
Messages
4,634
Reaction score
3
I am having trouble downloading my last flight data from my Alt15K/WD altimeter to my Win Vista laptop. It looks like the drivers install ok.

I select a COM port (I guess which one, if that doesn't work I try another), then try to acquire the data. I get the following errors:
MRF Range Error
Error in data length: 2
Communications error. Check cables and retry transfer.
The "funny" thing is that I have done this before and it worked. I just don't know what the issue is this time.

Can anyone suggest a recommended course to resolve this?

Greg
 

sumo310b

Active Member
Joined
Apr 13, 2009
Messages
27
Reaction score
0
Are you sure the drivers are installed OK? I had similar issues with my MAWD and WinXP a few months ago, this was the solution (not sure if the same applies to your alt/Vista though):

There are 2 drivers that need to be installed before installing the Perfectflite MAWD software, the "USB <-> Serial" and "USB Serial Port".

I had other drivers installed, which I manually updated, from the Perfectflite download / CD-ROM data. From memory the 'FTDI' driver dates are 12/12/2005 for both the USB Serial Port (COM#), and the USB Serial Converter. The computer needs to be restarted after updating the USB <-> Serial driver.

So... this got the drivers installed, but the Data Capture program still wasn't recognising my COM ports. On my PC I navigated to System / Hardware / Device Manager menu, I saw that the USB Serial Converter COM port was set to COM12 - through the COM12 properties, I manually forced this to COM2 (the first unused port), restarted the MAWD Data Capture program, and whaddya know, COM2 is there. After selecting COM2, I then went through the usual acquisition process. I chose "Identify Altimeter", which then worked.
 

GregGleason

Well-Known Member
Joined
Nov 13, 2009
Messages
4,634
Reaction score
3
Thank you, Sumo. For me you have provided a workable "road map" I can use to try to solve the communication issue. I am hoping that the devices are similar enough that the fix for one will work for the other.

I plan to try to fix it this evening.

Greg
 

GregGleason

Well-Known Member
Joined
Nov 13, 2009
Messages
4,634
Reaction score
3
The solution was to force the USB com port to a free port, which in this case was COM2. Once I did that, things worked fine.

I appreciate the help Sumo.

Greg
 

sumo310b

Active Member
Joined
Apr 13, 2009
Messages
27
Reaction score
0
Glad you've got it fixed, it can be a real pain to follow the manual and have it not work, then troubleshoot over and over.

Simon
 
Top