Quantcast

pdf problem, can anyone help?

The Rocketry Forum

Help Support The Rocketry Forum:

Woody's Workshop

Well-Known Member
TRF Supporter
Joined
Aug 3, 2011
Messages
4,286
Reaction score
186
Location
Reed City, Michigan (Lower)
When I click on a pdf document on the net, instead of opening it like it use to, it wants to download it and asks for a destination.
I don't think I did anything to change this. It's becoming a real PINA.
Does any one know how to fix this?
Win10/Firefox.
 

markkoelsch

Well-Known Member
Joined
Mar 18, 2009
Messages
4,364
Reaction score
148
Windows 10 by default wants to open PDF files in Edge- I would not use Edge for this, or any other browser.

Download Adobe Reader, and make it your default program for PDF files.

As to the having to download it first, I am not sure if there is a way around it. In reality, that always has had to have happened, but they for some stupid reason now make you have to do the additional step.
 

Woody's Workshop

Well-Known Member
TRF Supporter
Joined
Aug 3, 2011
Messages
4,286
Reaction score
186
Location
Reed City, Michigan (Lower)
Says 64 bit systems (which mine is) can't use the Acrobat Reader in Fire Fox, have to use the pdf reader that comes with Fire Fox.
That's funny, because it was working just fine. And now all it want's to do is download the file.
 

Marc_G

Well-Known Member
Joined
Jun 6, 2010
Messages
6,635
Reaction score
714
Location
Indianapolis Metro Area
OK Woody, do this:

In Firefox, go to Options (usually via the three line menu control in the upper right, select Options)

In Options select Applications

In the Applications window, go to the Search box that should be at the top and type PDF

It should show Portable Document Format on the left, and on the right it should have an Action. Be sure it is set to Preview in Firefox.

Probably right now it is set to Save File.
 

Woody's Workshop

Well-Known Member
TRF Supporter
Joined
Aug 3, 2011
Messages
4,286
Reaction score
186
Location
Reed City, Michigan (Lower)
That was easy, but save file is the only option.
What I think I'm dealing with here is when I tried to install Open Rocket, I changed something.
I'm guessing from what I've found out, I have to remove Acrobat Reader as my default program from pdf's.
Since you can't use Acrobat Reader directly from Fire Fox, it want's to save it. Need to change default program for pdf's.
Just have to figure that out, then should be set.
 

Marc_G

Well-Known Member
Joined
Jun 6, 2010
Messages
6,635
Reaction score
714
Location
Indianapolis Metro Area
Firefox has its own built in reader, which should show as an action, so something is squirrely here. Installing Adobe DC shouldn't change that. I'll install FireFox on this computer and see what I find.
 

John Beans

Founder, Jolly Logic
TRF Supporter
Joined
Jun 5, 2010
Messages
833
Reaction score
172
Can you right-click the link and get a Preview option?
 

Marc_G

Well-Known Member
Joined
Jun 6, 2010
Messages
6,635
Reaction score
714
Location
Indianapolis Metro Area
OK, this is what I see using Firefox 64 bit:

Firefox PDF actions.jpg

Make sure to click where it says Action to bring up the triangle for the drop down selector. So, for example on mine it says Preview in Firefox as the only "option" until I click where it says Action. Then, I can see all the options.

You definitely DON'T have to remove the windows default action for Adobe linked to PDFs.
 

Woody's Workshop

Well-Known Member
TRF Supporter
Joined
Aug 3, 2011
Messages
4,286
Reaction score
186
Location
Reed City, Michigan (Lower)
The drop down list for me has on save as.
I have to find out where Acrobat Reader is set to default, and change that to Fire Fox pdf viewer.

OK, this is what I see using Firefox 64 bit:

View attachment 310507

Make sure to click where it says Action to bring up the triangle for the drop down selector. So, for example on mine it says Preview in Firefox as the only "option" until I click where it says Action. Then, I can see all the options.

You definitely DON'T have to remove the windows default action for Adobe linked to PDFs.
 

Marc_G

Well-Known Member
Joined
Jun 6, 2010
Messages
6,635
Reaction score
714
Location
Indianapolis Metro Area
You mean the Windows default actions for PDFs? No, you definitely don't want to set that to Fire Fox PDF viewer. I don't even think it is possible to do it, unless it happens to be a stand alone program.

I recommend backing up your bookmarks, uninstall firefox completely, then do a fresh install of it. Then restore your bookmarks.

Marc
 

Woody's Workshop

Well-Known Member
TRF Supporter
Joined
Aug 3, 2011
Messages
4,286
Reaction score
186
Location
Reed City, Michigan (Lower)
I couldn't find anywhere to change the default to firefox reader.
After numerous searches, I did come across a FireFox Refresh.
So I did that. All I had to do is go back in and turn on all my add on's.
Everything is still here.
Just checked, and it's working fine again.
Thanks for everyone's help!
 
Top