Quantcast

OpenRocket -- JPGs I create do not show up to import as a texture.

The Rocketry Forum

Help Support The Rocketry Forum:

Bat-mite

Rocketeer in MD
Joined
Dec 5, 2013
Messages
10,986
Reaction score
1,738
Location
Maryland
OpenRocket gurus,

I followed the directions in other threads to apply decals to my model. I downloaded and installed Paint.net and created an image 20" X 9.3". I have it oriented so that the top of the rocket is the top of the image (not the left).

I saved it as a JPG. I opened the model in OR, went to the appearance tab for the component--

Repeat: Clamp Edge Pixels

Texture: From file...

All my pictures show up except the one I just made. I can put family pictures on the rocket, but I can't see my decal.

What am I dong wrong? Thanks.
 

MikeyDSlagle

Well-Known Member
Joined
Dec 17, 2013
Messages
2,432
Reaction score
424
Not familiar with paint.net but.
Double-check your save file path to make sure you have the file saved in the right place, or rather you are looking for it in the right place.
Check you are for sure saving it as a jpeg and not as jpeg2000 or some other format..
That's all I got ATM, hope it helps.
 

Bat-mite

Rocketeer in MD
Joined
Dec 5, 2013
Messages
10,986
Reaction score
1,738
Location
Maryland
Not familiar with paint.net but.
Double-check your save file path to make sure you have the file saved in the right place, or rather you are looking for it in the right place.
Check you are for sure saving it as a jpeg and not as jpeg2000 or some other format..
That's all I got ATM, hope it helps.
Nope, that's not it. But thanks. I'm guessing that JPEGs saved in a paint program are missing something that a camera-generated photograph has. But I really have no clue.
 

neil_w

Marginally Stable
TRF Supporter
Joined
Jul 14, 2015
Messages
11,066
Reaction score
3,908
Location
Northern NJ
I do all my OR decal work in Paint.net and have not had any problem (I'm assuming one of those "other threads" was mine). It produces perfectly "normal" output. Although I do the vast majority of my work with PNG files, not JPEGs. You could try saving it as a PNG and see if that makes any difference.

Can you post the image somewhere? You'll need to put it on Dropbox or some other sharing site where we'll be able to get it in its pure unaltered form (TRF sometimes alters the image during upload.)
 

Bat-mite

Rocketeer in MD
Joined
Dec 5, 2013
Messages
10,986
Reaction score
1,738
Location
Maryland
I do all my OR decal work in Paint.net and have not had any problem (I'm assuming one of those "other threads" was mine). It produces perfectly "normal" output. Although I do the vast majority of my work with PNG files, not JPEGs. You could try saving it as a PNG and see if that makes any difference.

Can you post the image somewhere? You'll need to put it on Dropbox or some other sharing site where we'll be able to get it in its pure unaltered form (TRF sometimes alters the image during upload.)
I will, and thanks! But I'm not sure when. I will be very busy tonight, and I have a busy weekend coming up. Hopefully I can find a few minutes Friday night to get it uploaded. If I can actually remember to do it, I will also try to remember to PM you.
 

neil_w

Marginally Stable
TRF Supporter
Joined
Jul 14, 2015
Messages
11,066
Reaction score
3,908
Location
Northern NJ
Well, the image is fine:
scorp_or.png

I would suggest PNGs for that sort of design (geometric, solid color), but the JPEG is totally normal and OK.

There are only two possibilities I can think of:
1) The file is there, but the sorting of the files in the open dialog is not what you think and you're just not looking in the right place. Sounds crazy, but it has happened to me before.
2) The folder needs to be refreshed. Windows is very weird and inconsistent about this. From the "Open File" dialog in OR, right click on the background and select "Refresh". See if the file appears.

Other than that... I dunno.
 

K'Tesh

OpenRocket Chuck Norris
TRF Supporter
Joined
Mar 27, 2013
Messages
14,835
Reaction score
1,256
I do all my work in MS Paint, I save them as .png files (I find I get less artifacts from compression using .png files).

I'd suggest saving your work, closing down OR, then reopening it. I find if OR's been running for a long time, it'll get stupid, and start forgetting to display the graphic elements. If I press on after that happens, I will typically get freezes ("program not responding") in OR, and if I'm really unlucky, it'll run out of memory, and refuse to do anything until it's closed using the task manager. A reboot is often desirable after that happens.
 

Nathan

TRF Supporter
Joined
Apr 20, 2012
Messages
2,128
Reaction score
436
deleted
 
Last edited:

Nathan

TRF Supporter
Joined
Apr 20, 2012
Messages
2,128
Reaction score
436
I downloaded your JPG file and tried using it as a texture on my fins. It worked fine for me too . . .

 

Bat-mite

Rocketeer in MD
Joined
Dec 5, 2013
Messages
10,986
Reaction score
1,738
Location
Maryland
Geez. I've tried everything you guys have suggested. In fact, I've rebooted several times in between. I know exactly where the file is. I can attach any other picture in the same directory. I have tried it in MS Paint and Paint.net. I have saved as a PNH and a JPEG. I have moved the file to a different directory and looked there. But no matter what I do, I cannot get OpenRocket to see it. It's baffling. Thanks for the suggestions.
 

Nathan

TRF Supporter
Joined
Apr 20, 2012
Messages
2,128
Reaction score
436
One last idea. Check Windows security settings for that file on your computer and verify that all users have full control permissions.
 

Bat-mite

Rocketeer in MD
Joined
Dec 5, 2013
Messages
10,986
Reaction score
1,738
Location
Maryland
One last idea. Check Windows security settings for that file on your computer and verify that all users have full control permissions.
A long shot, but will do!

If I am unable to get this to work, I'll be looking for a volunteer to take my OR file and my JPG file and see if you can do it on your machine.
 

neil_w

Marginally Stable
TRF Supporter
Joined
Jul 14, 2015
Messages
11,066
Reaction score
3,908
Location
Northern NJ
I can do that, PM me with appropriate DB link when ready.
 

Bat-mite

Rocketeer in MD
Joined
Dec 5, 2013
Messages
10,986
Reaction score
1,738
Location
Maryland
Nathan was right. Some kind of weird permissions. I moved the files out of my Pictures library into my Downloads folder, and then it could see them.

Scorpion finished.jpg
 
Top