Openrocket Error on Mac

The Rocketry Forum

Help Support The Rocketry Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


That Darn College Student
Mar 18, 2012
Reaction score
I know what you're all thinking. "What? BB using a mac?"

Yeah, no. Friend of mine is toying with Openrocket, and they're getting a RuntimeException when they try to start OR. When they click on the file in Finder, or use java -jar OpenRocket 15.03, they get the splash screen, and then they get the error message.

Fixes I've tried:
  • Redownloading OR
  • Updating java
  • Rebooting

Bug report attached. Any ideas on what to do?
I am befuddled by what kind of system variations could exist that could cause this sort of thing. I've never had this problem on any Mac or PC I've tried to run OR on. Since it's a Java app it really shouldn't (?) be too affected by much outside the Java installation itself, which should be the same from system to system. But I guess there are some external dependencies. Annoying.

So what I can offer for now is a packaged app version that I made a while ago. The packaged version for Windows has had 100% success rate as far as I can tell, and I suspect this will work for your friend as well. Give it a try.
Ahh, I didn't know you had a mac version as well. :)

I tell all my friends to use the .exe install you made, it eliminates a lot of problems (for example, high DPI screens don't mess up when installed with the packaged version).

I'll let her know and report back. :

You are a god. :)
Glad it worked. :)

I think I'm gonna recommend to the OR devs that they distribute packaged versions and deprecate using the raw JAR file. Sure seems to eliminate a lot of problems for a lot of people.
As another note, the .exe fixes the problems with a high-res screen.
Based on the error log, it appears BlackBrandt has Java 9 installed natively on the Mac and it's trying to reference javax.* classes that no longer are part of JRE 9. OR was built against Java 8. I'm assuming your bundled .dmg image has Java 8 included?