New Eggtimer Quantum Firmware Release (1.09F)

The Rocketry Forum

Help Support The Rocketry Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

cerving

Owner, Eggtimer Rocketry
TRF Sponsor
TRF Supporter
Joined
Feb 3, 2012
Messages
6,572
Reaction score
6,071
We have posted a firmware update for the Eggtimer Quantum on our Support page ( eggtimerrocketry.com/eggtimer-quantum-support/ ), rev. 1.09F. This fixes a user-discovered bug in the Auto-Arm function... the Quantum wouldn't arm if Auto-Arm was turned on and at least one of the outputs was set to Servo mode. If you're going to be using servos, or if your Quantum's version is below 1.09C, we recommend that you apply this update.

As usual, thanks for your support!

Cris Erving, Eggtimer Rocketry
 
1) Have you used this cable with Putty or something else to make sure that the driver is correct?

2) Did you change the com port to COM2? (Don't change the .bat file, change the port instead.)

3) Did you short the two PGM pads before powering on the Quantum?

Flashing the WiFi processors is MUCH easier than the Atmel processors (LCD, TRS, EVM)... it's not timing-dependent.
 
1)I have not tried the cable with anything else
2)I changed the COM port in the .bat file. Not sure how to change it elsewhere
3)I did short the PGM pads before powering. I have a 2 battery setup. Do I need both batteries?
 
So I figured out how to change the COM port and set it back to 2 in the .bat file. The attached file is what I get now.
 

Attachments

  • Quantum2.txt
    535 bytes · Views: 0
Your .BAT file is still set to COM8... change that and you should be fine. And yes, connect both batteries but do not put anything on the outputs when you're flashing it.
 
I went back to the .bat file and noticed it hadn’t saved my changing it back to port 2. Changed that and mace sure it saved it. After that it was back to doing what it did in my first post. I am also having an issue with testing the outputs. Using a random LED and resistor which works fine on the main output but not on the drouge output. If i connect the LED to the drouge output then power the Quantum it just makes a steady noise and wont power on up. If I power the Quantum then connect the LED shows the drouge channel as on and goes through the entire test countdown but the LED does not light. Maybe it doesn’t like the resistance of my LED setup?
 
LEDs have polarity so they must connect to the circuit in the correct direction.
Try reversing the connections on the Drogue channel.

Just to have Continuity just use a resistor (no LED).
 
If I switch the polarity of the LED it doesn't even show the channel on.
Re-read your post and I miss understood. Thought you were not getting continuity.
Is this the SAME LED & resistor that worked on the Main Channel?

What happens if you connect Only a resistor to the Drogue channel, 100 to 470 Ohm will work?
Then a Voltmeter across the resistor for 'fire' test.

There could be a bad solder joint somewhere. Go over the board with a 10X magnifier and good light.
I use low Voltage xmass tree bulbs for testing.
 
I can get no communication with my computer through the USB to serial connection. The computer recognizes the adapter and the light on the adapter comes on.
I was using the same LED for both channels and it does work on the main channel.
 
#1 suspect is the driver chips. Make sure that you get solder UNDERNEATH the leads so that they contact the PC board pads.
 
Looks like I will have to order another one. Didn't really see any problem. Removed the drogue channel driver and soldered it back on. It acted just like before. Messed around some more and now it does absolutely nothing.
 
Back
Top