MMX Launch problems

The Rocketry Forum

Help Support The Rocketry Forum:

lipp

Well-Known Member
Joined
Sep 5, 2004
Messages
116
Reaction score
0
I just bought a quest micro maxx set with the silo and critical mass. I tried to launch it today, but of course it didn't work. I had the thing all set up and the controller was beeping but with no luck. igniter wouldn't get hot I guess. any feed back is more than welcome
 

SwingWing

Well-Known Member
Joined
Jan 18, 2009
Messages
1,874
Reaction score
172
Make sure the engine is down over the ingitor all the way and that you have a good fresh battery. It can be a trick sometimes to ensure that the engine is all of the way down over the ignitor shoulder.
 

Karl

Well-Known Member
TRF Supporter
Joined
Jun 30, 2010
Messages
2,460
Reaction score
27
The 9v PP3 battery has hardly enough power to ignite the MMX Ignitors. Try using your normal controller ( Proton Beam ect ) . Just un-coil the posotive & negative wires of the ignitor , and wire up the clips. Maybe Micromeister could chime in here.
If your looking into MMX , you should join the MMX Yahoo group.
Karl
 

lipp

Well-Known Member
Joined
Sep 5, 2004
Messages
116
Reaction score
0
woh do i find the MMX yahoo group?????
 

rstaff3

Oddroc-eteer
Joined
Jan 18, 2009
Messages
11,763
Reaction score
22
The group has great info..lots of model plans, descriptions of how to mod your controller, and battery recommendations. I forget the best brand now that I use a 12v set up. You can get to the Yahoo Group here https://groups.yahoo.com/ You have to register, etc. The Group is called MicroMaxRockets (one 'x' due to Yahoo restrictions). When you sign up make sure you turn off all promotional material.
 

rocketkid88

Well-Known Member
Joined
Sep 22, 2009
Messages
412
Reaction score
0
thats sorta funny... i got an mmx set a little while ago, and last week when i went out to launch (i only had the tower/controller that came w/ the set on me) and the same thing happend. after a few no go's i just tried to get the ignitor to heat up w/o the rocket on... it worked once, after i had taken the ignitor part of the way appart. my theory was taht the connection wasn't that great between the ignitor/contacts... oh well, my 12v relay controller should fire them:) first i'm going to try a new batt tho...:rolleyes:
 

rstaff3

Oddroc-eteer
Joined
Jan 18, 2009
Messages
11,763
Reaction score
22
You could spring the internal terminals up a bit but I don't think thats the problem on a new set. micromeister tested several batteries and the results are on the website. Also, make sure you clean them after every few flights using a Q-tip. I get 2-3 flights before I clean them. But now I usually split the housing apart and use the igniter directly with a 12v source.
 

sandman

Well-Known Member
Joined
Jan 18, 2009
Messages
10,563
Reaction score
11
I have had really good luck (100% success) by just taping the igniter thingy to the launch rod and lowering the model on the igniter.

I just bend the little ends of the igniter wires out and hook my 14v Pro-Series launcher to them with the micro clips.

I threw all the silo parts away and saved just the launch rod.
 

BobH48

Well-Known Member
Joined
Jan 18, 2009
Messages
3,388
Reaction score
8
I read in another thread that there was problems with some of the silo launchers.

I can't seem to find the thread now but it said that there was a loose connection or short and that it would buzz but not light the igniter.

Sounds like your problem.
 

Stymye

Well-Known Member
Joined
Jan 21, 2009
Messages
7,599
Reaction score
6
I had that problem with the short in the pistol grip it would buzz but no ignition... I found the electron beam made a good substitute.. the igniters can be finiky
 

lipp

Well-Known Member
Joined
Sep 5, 2004
Messages
116
Reaction score
0
I read in another thread that there was problems with some of the silo launchers.
I beleive that is exactly what is wrong with mine. i'm gonna mod. to the electron like i been reading about...
 

gpoehlein

Well-Known Member
Joined
Jan 18, 2009
Messages
3,564
Reaction score
13
When I got my first mmx silo launcher and rockets, I bought a 9V battery along with it - from Toys R Us - and it was an off brand. Needless to say, I had the exact same luck as you did.

Actually, the new set specifically says to use a fresh Duracell or Energizer Alkaline 9 Volt - and only those two brands. Apparently, most all other brands (Ray o vac, etc) don't have enough juice to fire off the igniter. From what I understand, that igniter is like dead-shorting the terminals of the 9V battery - that that will kill a 9V faster than anything (It generates 9V, but the amperage is so low it is practically non-existent.

I rigged the launcher to work with my Big Foot pad - the four D-Cells fire off those mmx igniters without a single problem. One suggestion I read was to rig a four cell battery pack or even a 12V gel battery to a 9V battery clip - you can then plug it into the battery clip in your laund controller and fire them off easily.

So, bottom line - the 9V battery is most likely the culprit.

Greg
 

Micromeister

Micro Craftman/ClusterNut
TRF Lifetime Supporter
TRF Supporter
Joined
Jan 19, 2009
Messages
15,074
Reaction score
51
Location
Washington DC
Dicks suggestion about cleaning the contacts on the silo with a q-tip every so often is excellent if your going to continue to use the Silo.
another quick fix to the 9v battery problem is to convert it to 12 volts with a simple battery cable drop. I'll attach a photo of this connector. take that dead or nearly dead 9v battery apart with a pair of needle nose pliers, cut the _+ & - leads off with enough metal stip to solder on a 5 or 6 foot piece of 18/2 lamp cord or something similar, add to alligator clip to connect to a 12v power source of your choice. NO additional alterations need be made, the contorller and system will take the voltage increase just fine, I have one i've used off and on for almost 4 years without any ill effects. I filed a small cord hole in the corner of the controller 9volt battery compartment, attached the newly soldered 9v battery cap to the controller connector, slipped the combo into the controler and closed the door. Works like a champ!
Another suggestion with the old plug in type connectors is to trim off the excess paper sticking out both sides of the connector to make inserting and removal easier. just cut the papers off flush with an x-acto knife when you take them out of the motor pack. Of coused the best alteration is to go to a standard 12v controller system. There are several in the files section of the MicroMaxRockets group.l
 
Top