Quantcast

low current ejection charge igniters?

The Rocketry Forum

Help Support The Rocketry Forum:

billdz

Well-Known Member
Joined
Feb 11, 2017
Messages
1,224
Reaction score
76
[FONT=&quot]Today I tried my first ground test with a Telemetrum and a Wildman WM02 election lighter. The igniter did not fire. I asked Keith at Altus Metrum what might be wrong and he replied, "What kind of igniter are you using? Our boards are designed for low-current systems like ematches." The Wildman website does not provide any specs for the WM02, does anyone know how much current they require? If they require more current than the Telemetrum can provide, any sources for low current igniters? I see the Quest Q2G2 is a favorite low current choice, but it's out of stock everywhere.[/FONT]
[FONT=&quot]
[/FONT]

[FONT=&quot]Thanks,[/FONT]
[FONT=&quot]Bill
[/FONT]
 

markjos

Well-Known Member
TRF Supporter
Joined
Dec 21, 2010
Messages
317
Reaction score
53
Are you new to the Telemetrum operation, and have you fired any other e-matches with it? The Telemetrum should absolutely fire the Wildman Ejection lighters. I've used tons of them, with and without cardboard tubes, for years with Telemetrums, PerfectFilte Stratologgers and MAWDs, and Featherweight Ravens. I don't have the firing current data in front of me, but they're pretty typical. Do you have a decent multimeter? I find that these "lighters" are generally 1.2 - 1.8 ohms, depending on the wire length, so should have no trouble at the 3.7V (nominal) provided by the 1S Telemetrum LiPo battery.

You should be able to see real-time voltage on the deployment channels of the Telemetrum - before and after firing. In case this is new to you, take your time to learn its operation, and the difference between the various modes (pad, idle, etc.). This is an incredibly capable device, but some aspects do require a bit of study, so take your time with it.

Good luck - you'll get this figured out, and I'm sure will enjoy using the Telemetrum in the long run.

Mark
 

billdz

Well-Known Member
Joined
Feb 11, 2017
Messages
1,224
Reaction score
76
Mark,
I have had my Telemetrum since February and it is truly an incredible device. Until today, I had only used it to obtain and graph flight data. Today was my first attempt to use it to fire any type of igniter. I've also purchased from Wildman and know his products are of the highest quality. Yes, the Wildman lighters are reading 1.3 ohms on my meter. And AltOS is showing the battery at 4.1 volts. So I'm puzzled why it is not firing.

I just tried it again with a different Wildman WM02, same result, no fire. This time, I did not have the lighter in a rocket, I put it under a thick glass jar. The LED on the TM flashes when I click on Fire, but nothing happens with the lighter. Then I tried with a different device, an Eggtimer Quark, which uses the exact same battery. With the Quark, the lighter fired immediately. Keith suggested placing an LED across the terminals instead of a lighter, the LED should light up at firing. So now I'm searching the house for an LED, I must have a few somewhere, but this test will have to wait for tomorrow unless I find it soon.
 

blackjack2564

Crazy Jim's Gone Banana's
TRF Supporter
Joined
Jan 18, 2009
Messages
9,112
Reaction score
1,251
Location
Savannah Ga
If you have an old string of "mini" xmas lights. cut one off they work well also.
 

blackjack2564

Crazy Jim's Gone Banana's
TRF Supporter
Joined
Jan 18, 2009
Messages
9,112
Reaction score
1,251
Location
Savannah Ga
By the way...do you have a jumper on the pyro to lipo on the telemega?

If only using a single battery it must be on to "fire" charges. Otherwise led blinks, but no fire...

I FORGOT ONCE ALSO...LOL

Screen Shot 2017-05-14 at 11.30.09 PM.png
 

markjos

Well-Known Member
TRF Supporter
Joined
Dec 21, 2010
Messages
317
Reaction score
53
So are you powering up the Telemetrum in Idle Mode (horizontal), and using the Fire Igniter window? Are you hearing the appropriate continuity beeps for the deployment channel to which you've connected the e-match? Just to confirm the steps you're taking: select the channel in the Fire Igniter Window, which presumably shows "Ready" (rather than "Open")? Click "Arm" and then "Fire" within the 10 second countdown time? Does this all sound like what you're doing?

You should also be able use the Monitor Idle window, and not only see the battery voltage, but also the Apogee Igniter Voltage and Main Igniter Voltage. The channel to which you have the e-match (lighter) connected should show something close to battery voltage.

I'll assume that you would have mentioned if you suspected that the altimeter had experienced any damage - either physical or electrical (miswired outputs or switch terminals, etc).

I'll look forward to hearing more, and I'll try to help, though someone else might see something we're missing.

[I just saw Jim's post - Good point! yeah, make sure that the unit isn't configured to use a separate pyro battery - that would be a problem!]

Mark
 
Last edited:

billdz

Well-Known Member
Joined
Feb 11, 2017
Messages
1,224
Reaction score
76
@Jim - I have a Telemetrum, not a TeleMega. I don't see anything in the TeleMetrum instructions about a jumper. Would be great if I could solve the problem with a simple jumper.

@Mark - Yes, Idle mode, Fire Igniter window, Apogee "Ready" (have not tried Main), continuity "dit" beep sounding, click Arm, click Fire within 10 seconds. Apogee Igniter Voltage showing 4.1v. Nothing miswired to my knowledge. The device was in the rocket during a hard landing but except for this issue it seems to be working properly.

Update - I decided to try Main and it did fire, although there was at least a second of delay between the time I clicked Fire and the time of firing.
 

billdz

Well-Known Member
Joined
Feb 11, 2017
Messages
1,224
Reaction score
76
Not looking good, Keith says to send the TM in for service. The TM fires properly every time on the Main channel, only the Apogee side is not working (even though it says Apogee "Ready"). Keith said the one second delay between clicking fire and firing is normal.
 

markjos

Well-Known Member
TRF Supporter
Joined
Dec 21, 2010
Messages
317
Reaction score
53
Too bad that it appears damaged, but I'm sure Keith and Bdale will take good care of things for you. If it wasn't firmly mounted for previous flights, then I guess it's time for some sled and av-bay building. There are plenty of creative ways to do that.

Best wishes on future flights with it!

Mark
 

billdz

Well-Known Member
Joined
Feb 11, 2017
Messages
1,224
Reaction score
76
@Tim - Yes, although now it's on a sled, as recommended in that thread. I had almost forgotten about that flight, it was the only time the data stream stopped before the rocket landed. Are you going to go to the Palm Bay launch on Saturday (if not canceled due to fire hazard)?
@Mark - Yes, Keith and Bdale provide great customer service.
 

timbucktoo

Well-Known Member
Staff member
TRF Supporter
Global Mod
Joined
Jun 13, 2014
Messages
8,115
Reaction score
1,279
Location
Cocoa Beach
@bill - that's my plan. Keep your fingers crossed and let's hope we get some rain. So it's flown since that flight?
 

billdz

Well-Known Member
Joined
Feb 11, 2017
Messages
1,224
Reaction score
76
Yes, several times, although it was never used for electronic deployment. Do you know how far in advance they make the go/no go decision on the launch? Thunderstorms are forecast for Friday. Hope to see you there.
 

timbucktoo

Well-Known Member
Staff member
TRF Supporter
Global Mod
Joined
Jun 13, 2014
Messages
8,115
Reaction score
1,279
Location
Cocoa Beach
Usually the call is made Friday. Pray for rain!
 
Top