GPS Rocket Locator saving maptiles

The Rocketry Forum

Help Support The Rocketry Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Well-Known Member
TRF Supporter
Nov 25, 2009
Reaction score
Central Illinois

I have a bunch of maptiles saved for offline use with GPS Rocket Locator. Since I don't want to go through the laborious process of downloading them again from Wifi (plus the "pretty maps" are no longer available)
I'm trying to get them off for backup as I like to dink with custom ROMs on these old Nexus 7's. Wipe the system clean and reload and the maps will "disappear" along with all the stored photos and such.

Well, I had no troubles with offloading copies of maptiles of 300mb or thereabouts but now with 586mb it is a royal hassle. The download process quits at three hundred eighty or ninety sumpthin megabytes on a WinBlows
or my precious Ubuntu laptop. I'm aghast my Linux distro is failing me!:sigh: Chute, it's the same distro I root the Nexus tablets with seamlessly and simply in the first place!:shock:

Oh, this worked in the past. I offloaded a smaller number of maptiles, whacked, er erased and reloaded an N7 with a custom ROM and then put the maptiles back in and they worked fine.

Soooooooo, what's a body to do? I'm batch transferring the tiles to a desktop. I connect it up to a Win 7 computer at work and surprisingly it recognizes my N7 2013 LTE and can see its directories.
Well yeah when I click on the directory that's on the N7 from Win 7 and try to copy it to the desktop machine, it craps out at 388mb or so. Doesn't work after multiple and lengthy attempts.
There's 584mb more or less on there. Going inside the directory under /mapCache I can have Windows tag all the tiles and it does come out to 584mb. If I hand tag (which takes time as there is no
"tag all" option I can find anymore) and try to transfer all in one sitting, it times out well before 584 mb is transferred.

Well, I'm batch transferring but tagging several files and copying them. The first 100mb did pretty good but I'm trying to suck out more and it's taking longer. In fact it's quite a bit slower. Those 584mb occupy more than
700mb of space.

Now I have my home city in there at various zoom levels and the two sites I fly at I've copied in as close as I can get for several miles around. It's like I can see the telephone pole wires close which is kinda nice.
Oh boy, I just checked. Windoze says only 4hours and 15 minutes left woo hoo. Then one more batch and I'm done. At least this machine has 450gb of space open.

If anyone took the time to download maptiles with GPSRL I recommend you try and backup your tiles off your device if you can. Using the program online didn't save the tiles. One had to go to the upper right pull down menu and hit
"download map" at the bottom. They had to do it for "every" zoom level they wanted to save to their device. Yeah, it took a lot of time and if one did that, it behooves them to backup for safe keeping 'cause I don't
think the author Francois is going to pull off a fix to bring back the pretty pictures. I think he's done messing with it as I believe he put the code up in a public place like Git-hub or something. I don't know how to code
otherwise I'd give it a go. Ok so I did code but that was on an HP mini computer in Fortran and Basic in the mid 70's. I know what a bootstrap tape is and knew how to put the initial address in Octal to fire off the bootstrap and
then load the OS tape. No RTC chips or BIOS in those days!! Removable hard drive, 20mb was nearly as like a large locker a little smaller than a phone booth. You do remember those don't you?

If one can't find the /mapCache directory it might be because it's not visible with an unrooted device. In that case, one would have to be very very careful not to mess up or reset their Android device and play nicely with it.
If you can find it on an unrooted device and move stuff around they're in good shape to work with it.