Eggtimer classic question (again)

The Rocketry Forum

Help Support The Rocketry Forum:

Ccolvin968

Well-Known Member
Joined
Oct 11, 2016
Messages
314
Reaction score
0
Good morning everyone!
It's been a while. Family issues and life have been going on.
So... Down to business!

I tried connecting a 9v battery with a standard connector to my deployment channels yesterday night.
After I attached them, I plugged in the battery. A few minutes later it was very warm, almost hot to the touch.
Do I have a short circuit somewhere? Or do I have to turn the entire board so it doesn't do that?
I ran out of time last night. Any advice is appreciated!
 

soopirV

Well-Known Member
Joined
Sep 1, 2010
Messages
1,157
Reaction score
6
I'll cook again. Thanks!
If it's the original original Eggtimer, I think you might've cooked it...IIRC, it only accepts 3.3v input. It wasn't until later that a V-Reg and option to juice from another source was added...but I could be mixing things up. I have several at home, but am not there right now to look, and I haven't the time at the moment to look at the website...sorry!
 

Ccolvin968

Well-Known Member
Joined
Oct 11, 2016
Messages
314
Reaction score
0
It's not fried. The board still works. I'm using LiPo for board power, then 9v for the deployment channels.
 

Ccolvin968

Well-Known Member
Joined
Oct 11, 2016
Messages
314
Reaction score
0
Me too! I'll have to check it tomorrow. Unfortunately I don't have time tonight.
I'll post once I figure out what is going on.
 

Ccolvin968

Well-Known Member
Joined
Oct 11, 2016
Messages
314
Reaction score
0
Yeah, I'm an idiot...
I hooked up a 9v after I had already hooked up my LiPo battery to the deployment channels.
Test went great and both went off without a hitch... Except my absolute and utter inattentiveness.
Problem solved! I'll be launching on July 8th 2017 for my L2 and the Eggtimer classic on board!
 

Latest posts

Top