All of a sudden I keep getting logged out

The Rocketry Forum

Help Support The Rocketry Forum:

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
I used to stay logged in... pretty much forever. Now over the last day or two I've had to re-login several times. Has anything changed?

Using Chrome on MacOS.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
As a bonus, when I went to post the above message it forced me to log in again.

And I *do* check the "Stay logged in" box.
 

CalebJ

Well-Known Member
TRF Supporter
Joined
Jan 20, 2020
Messages
397
Reaction score
224
Not experiencing it here. Any chance you changed a setting relating to storing cookies?
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
Nope, no changes. It seems to only be affecting my Mac; Chrome on Windows is experiencing no issues at the moment.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
Nope, no changes. It seems to only be affecting my Mac; Chrome on Windows is experiencing no issues at the moment.
Scratch that, just happened on my Windows machine.
 

CalebJ

Well-Known Member
TRF Supporter
Joined
Jan 20, 2020
Messages
397
Reaction score
224
Odd. I'm trying to visualize anything happening on the ISP side that could cause it. Have you been able to duplicate it using a different connection (cell based, etc)?
 

timbucktoo

Well-Known Member
Staff member
TRF Supporter
Global Mod
Joined
Jun 13, 2014
Messages
7,192
Reaction score
927
Location
Cocoa Beach
I had something similar using Firefox but it was in my settings.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
Odd. I'm trying to visualize anything happening on the ISP side that could cause it. Have you been able to duplicate it using a different connection (cell based, etc)?
My only option right now is to connect via my home Wifi. I do not have this problem with any other site.

I had something similar using Firefox but it was in my settings.
Can you recall what the setting was? I haven't changed anything anywhere and now it's happening on both my machines.
 

timbucktoo

Well-Known Member
Staff member
TRF Supporter
Global Mod
Joined
Jun 13, 2014
Messages
7,192
Reaction score
927
Location
Cocoa Beach
In firefox, under Options -> Privacy & Security -> Scroll down to History then click on Settings.
This is what I have selected and fixed my problem. I was getting logged out of some really basic stuff.
upload_2020-3-19_9-54-18.png
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
OK, I just nuked *everything*, all history, cookies, cache, you name it. We'll see if it gets better.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
No help at all, still happening. I'm really the only one having this? Oy.
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
Nothing in our settings have changed.
 

Speaknoevil

Well-Known Member
Joined
Mar 18, 2018
Messages
1,144
Reaction score
517
This is happening to me too. I get logged out every couple of days.
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
Have you shut down your computer in the last few days so it can do a hard reboot?
If on the app, please uninstall and reinstall, that fixes most quirky things that start happening.
If you can clear history and cookies, and possibly even cache. Then try again.
 

Speaknoevil

Well-Known Member
Joined
Mar 18, 2018
Messages
1,144
Reaction score
517
Have you shut down your computer in the last few days so it can do a hard reboot?
If on the app, please uninstall and reinstall, that fixes most quirky things that start happening.
If you can clear history and cookies, and possibly even cache. Then try again.
I have for other reasons, but this happens on across all devices (2 computers, one pad, and one phone).
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
I have for other reasons, but this happens on across all devices (2 computers, one pad, and one phone).
Darn, I don't see what may be happening. But running a maintenance in the off chance it helps.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
Glad I’m not the only one, helps my sanity a bit. For me the log off interval is highly variable but has been as short as 15 minutes on my Windows machine.

I feel like we went through this once before, gotta go look through forum history to see how it was resolved.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ

CalebJ

Well-Known Member
TRF Supporter
Joined
Jan 20, 2020
Messages
397
Reaction score
224
Are you consistently connecting to TRF using https url's?
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
I've reported it so site and server can be checked on.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
Good grief this is driving me nuts. Just had to login twice in 5 minutes.
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
Are you using an old link? And have you cleared the cookies for this site?
Are you using a phone and mobile browser.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
I'm using current links as far as I know.

Interestingly this doesn't seem to happen on my phone (iPhone/Safari), at least not yet. Happens on a Mac and a Windows 10 laptop, both using Chrome. I totally nuked cache, cookies, and everything; it made no difference.

I think I tried other browsers but I don't remember details so I'll try again.
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
Please delete old link. Get on the forum, save to favorites again. Now try logging in.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
I'm not sure what that means. I often start from my alerts page (https://www.rocketryforum.com/account/alerts); that link is fine. I can encounter the login prompt while doing anything, like opening a thread, making a posting, or anything, using current links.

On multiple occasions I have encountered the login prompt when I hit "Post Reply" after entering a new reply.
 

Angie

Administrator
Staff member
Administrator
Global Mod
Joined
Jul 29, 2016
Messages
1,736
Reaction score
374
What I mean is:
1. Delete the link for your alerts.
2. Type in the forum name on your browser.
3. Log in
4. Go to alerts
5. Save this new link.

Now see if you stay logged in.
 

neil_w

Hunkered down and slowly going crazy
TRF Supporter
Joined
Jul 14, 2015
Messages
9,037
Reaction score
2,378
Location
Northern NJ
I just tried that and it made no difference, which is not surprising because the URLs stayed exactly the same.

Next I'm trying whitelisting the site in Ghostery, which is not an appealing solution but I'm curious to see if it could possibly be connected.
 

Latest posts

Top